Diagnostisch hulpprogramma voor DirectX

De documentatie van het diagnostisch hulpprogramma voor DirectX® van Microsoft® bevat de volgende onderwerpen:

  • Informatie over het diagnostisch hulpprogramma voor DirectX
  • De oorzaak van een probleem opsporen
  • DirectX-onderdelen testen
  • Standaardgedrag wijzigen


Informatie over het diagnostisch hulpprogramma voor DirectX

In het diagnostisch hulpprogramma voor DirectX® van Microsoft® wordt informatie verzameld over de DirectX API-onderdelen (Application Programming Interface) en -stuurprogramma's op uw systeem. Met dit hulpprogramma kunt u geluid, grafische uitvoer en Microsoft DirectPlay®-serviceproviders testen. Ook kunt u met dit hulpprogramma bepaalde functies voor hardwareversnelling uitschakelen.

U kunt dit diagnostisch hulpprogramma gebruiken om gegevens te verzamelen voor de technicus voordat u de technische dienst belt. Het is ook mogelijk de gegevens die het programma heeft verzameld, op te slaan en in een e-mailbericht te plakken.

De gegevens worden op een reeks pagina's weergegeven. U kunt op de volgende manieren van de ene naar de andere pagina gaan:

  • Klik op de tabs.
  • Klik op de knop Volgende pagina.
  • Druk op PIJL-LINKS of PIJL-RECHTS als een tab de focus heeft.

U kunt opgeven hoe de tabellen in dit hulpprogramma moeten worden weergegeven. Kies daartoe de kolom op basis waarvan u de tabelrijen wilt sorteren. Klik op de knop met de kolomkop boven aan de desbetreffende kolom. De tabel wordt gesorteerd op basis van de items in deze kolom die in alfabetische of numerieke volgorde worden geplaatst. Als u de sorteervolgorde wilt omkeren, klikt u nogmaals op de knop met de kolomkop.

U kunt op de knop Alle gegevens opslaan klikken om alle gegevens in een tekstbestand op te slaan.

Opmerking

  • Sommige waarden, zoals de hoeveelheid geheugen op een beeldschermkaart, zijn mogelijk globale waarden.


De oorzaak van een probleem opsporen

Als zich problemen voordoen bij het uitvoeren van Microsoft® DirectX®-toepassingen, kan het diagnostisch hulpprogramma voor DirectX u helpen de bron van de problemen te vinden. Hier volgen enkele mogelijke oorzaken van problemen die het diagnostisch hulpprogramma kan opsporen:

  • Onjuiste versies van DirectX-onderdelen. Zoek in de sectie Opmerkingen van de pagina DirectX-bestanden naar waarschuwingen over bèta- en foutopsporingsbestanden (debug-bestanden). Bètabestanden zijn vroege testversies van bestanden die niet samen met commerciële toepassingen dienen te worden geïnstalleerd. Foutopsporingsversies van bestanden worden gebruikt bij de ontwikkeling van programma's en dienen ook niet samen met het eindproduct te worden geïnstalleerd. Deze onderdelen kunnen ertoe leiden dat toepassingen aanzienlijk langzamer werken dan wanneer de toepassingen worden uitgevoerd met de handelsversies van de onderdelen.
  • Geen hardwareversnelling. Sommige programma's worden zeer langzaam of helemaal niet uitgevoerd tenzij hardwareversnelling van Microsoft DirectDraw® of Direct3D® beschikbaar is. Kijk op de pagina Beeldscherm onder DirectX-functies om na te gaan of DirectDraw-versnelling, Direct3D-versnelling of AGP-oppervlakteversnelling is gemarkeerd met 'Niet beschikbaar'. Als dat het geval is, kunt u overwegen uw hardware bij te werken.
  • Het apparaat is niet aangesloten. Als een joystick of een ander invoerapparaat niet reageert, is het mogelijk niet op de juiste manier ingesteld. Controleer of het apparaat voorkomt op de pagina Invoer van het diagnostisch hulpprogramma voor DirectX. Als dat niet het geval is, voegt u het apparaat toe via het Configuratiescherm.
  • Niet gecertificeerde stuurprogramma's. Microsoft heeft niet-gecertificeerde stuurprogramma's niet getest om vast te stellen of deze volledige compatibel zijn met de nieuwste versie van DirectX. Deze stuurprogramma's worden weergegeven op de desbetreffende onderdelenpagina.

Opmerking: als u Terminal Services gebruikt om te werken op een extern systeem dat hardwareversnelling ondersteunt, geeft het diagnostische hulpprogramma voor DirectX mogelijk aan dat ondersteuning voor hardwareversnelling beschikbaar is. Terminal Services kan echter niet werken met hardwareversnelling, dus is ondersteuning voor hardwareversnelling niet beschikbaar.


DirectX-onderdelen testen

U kunt Microsoft® DirectDraw® en Direct3D® testen op elke monitor die op uw systeem is aangesloten. Ook kunt u DirectSound® testen op elk wave-uitvoerapparaat en kunt u DirectMusic® testen op elke muziekpoort.

Als u een DirectX-functie wilt testen, klikt u op de knop Testen op de pagina voor de functie die u wilt testen, leest u eventuele berichten die worden weergegeven, en kijkt of luistert u naar de tests. Voer de test helemaal uit totdat er een bericht wordt weergegeven waarin aan u wordt gevraagd of de test geslaagd is. Als u Nee antwoordt, worden er geen andere tests meer uitgevoerd.

Als u DirectMusic test, wordt er slechts één test uitgevoerd. Klik op OK als u met zekerheid hebt kunnen vaststellen dat de muziek al dan niet op de gewenste manier wordt afgespeeld.

U kunt de Microsoft DirectPlay®-functionaliteit en elke beschikbare serviceprovider testen.

DirectPlay testen

  1. Klik op DirectPlay testen op de pagina Netwerk. Typ in het dialoogvenster DirectPlay testen een gebruikersnaam en kies een serviceprovider. Selecteer Nieuwe sessie maken en klik op OK. Als u een modemverbinding hebt gekozen, klikt u in het dialoogvenster Modemverbinding op Antwoorden om de modem op de modus voor automatisch beantwoorden in te stellen.
  2. Voer het diagnostische hulpprogramma voor DirectX® van Microsoft uit op een andere computer die de geselecteerde verbinding kan maken met de eerste computer. Klik op DirectPlay testen, typ een andere gebruikersnaam, kies dezelfde serviceprovider, klik op Deelnemen aan bestaande sessie en klik op OK.

    Voor bepaalde soorten verbindingen moet u mogelijk meer gegevens opgeven, zoals een telefoonnummer. Als u een TCP/IP-verbinding wilt maken via een lokaal netwerk, kunt u het tekstvak leeg laten.

  3. Selecteer op de tweede computer in de Sessielijst, die de naam bevat van de sessie die u op de eerste computer hebt gemaakt, de naam van de sessie en klik op OK.
  4. Op beide computers moet nu een chatvenster worden weergegeven. Typ een bericht in het invoervak op de ene computer en klik op Verzenden. Als het goed is, wordt het bericht nu in het schuifgebied van het chatvenster op beide computers weergegeven.


Standaardgedrag wijzigen

Op de pagina Geluid kunt u een ander niveau instellen voor de hardwareversnelling door de schuifregelaar te verschuiven. Dit niveau blijft van kracht nadat u het diagnostisch hulpprogramma voor DirectX® van Microsoft® hebt gesloten.

U kunt de hardwareversnelling voor Microsoft DirectDraw® of Direct3D® uitschakelen, als deze versnelling beschikbaar is. Als u de hardwareversnelling wilt uitschakelen, gaat u voor elk weergaveapparaat naar de pagina Beeldscherm en klikt u op de knop Uitschakelen. Als u de hardwareversnelling eenmaal hebt uitgeschakeld, is deze versnelling, zelfs nadat u het diagnostisch hulpprogramma voor DirectX hebt gesloten, voor geen enkele toepassing meer beschikbaar. Als u de hardwareversnelling opnieuw wilt inschakelen, klik u op Inschakelen op de beeldschermpagina's voor de gewenste apparaten.

Opmerking

  • Als u de DirectDraw-versnelling uitschakelt, schakelt u daarmee ook de versnelling voor Direct3D uit.

U kunt ook de vernieuwingsfrequentie van de monitor wijzigen die door de DirectDraw-toepassingen voor weergave op volledig scherm is ingesteld. U dient deze wijziging alleen aan te brengen als u daadwerkelijk problemen hebt met de weergave van een toepassing op het beeldscherm en u ervan overtuigd bent dat de toepassing een ongeldige vernieuwingsfrequentie instelt.

Een andere vernieuwingsfrequentie instellen

  1. Klik op de knop Wijzigen op de pagina Meer Help.
  2. Voer in het invoervak van het dialoogvenster DirectDraw-vernieuwingsgedrag wijzigen een geldige vernieuwingsfrequentie in voor uw monitor.

    Het keuzerondje Andere waarde wordt automatisch geselecteerd als u dit doet.

  3. Klik op OK.

De gewijzigde vernieuwingsfrequentie annuleren en DirectDraw-toepassingen toestaan hun eigen vernieuwingsfrequentie in te stellen

  1. Klik op de knop Wijzigen op de pagina Meer Help.
  2. Selecteer in het dialoogvenster DirectDraw-vernieuwingsgedrag wijzigen het keuzerondje Standaard en klik op OK.